Errors creating and modifying sequencer campaigns
November 13, 2025 at 03:49 PM EST
Resolved after 5h 40m
Updates
Resolved
We've fully resolved this issue.
November 13, 2025 at 09:30 PM EST
Identified
We've identified the problem as a third party provider experiencing an outage. We are working with their team to mitigate the impact. Next update when we have more information.
November 13, 2025 at 05:34 PM EST
Investigating
Users are experiencing errors creating, updating, and launching new sequencer campaigns. Next update in one hour or when we have more information.
November 13, 2025 at 03:49 PM EST