Back

Upstream provider causing issues with find email actions.

October 31, 2025 at 11:29 AM EDT Resolved after 6h 21m

Updates

Resolved

Our upstream provider resolved the issue at about 4:30pm ET. This is the final update.

October 31, 2025 at 05:51 PM EDT
Investigating

We have no updates at this time. Our upstream provider is continuing to look into the issue.

We'll provide updates in three hours or sooner if we have more information.

October 31, 2025 at 03:30 PM EDT
Investigating

We have no updates at this time. Our upstream provider is continuing to look into the issue.

We'll provide updates in an hour or sooner if we have more information.

October 31, 2025 at 02:35 PM EDT
Investigating

We have no updates at this time. Our upstream provider is continuing to look into the issue.

We'll provide updates in an hour or sooner if we have more information.

October 31, 2025 at 01:28 PM EDT
Identified

Our upstream provider has acknowledged the issue on their end and is working on fixing the issue.

We'll provide updates in an hour or sooner if we have more information.

October 31, 2025 at 12:25 PM EDT
Identified

We're currently experiencing technical issues with an upstream provider that may impact actions related to retrieving emails, including waterfalls

We'll provide updates in an hour or sooner if we have more information.

October 31, 2025 at 11:29 AM EDT