Back

Errors on the overview tab (workbooks)

July 16, 2025 at 06:28 AM EDT Resolved after 4h 38m

Updates

Resolved

We’ve fully resolved the issue.

July 16, 2025 at 11:06 AM EDT
Investigating

We're currently investigating an issue causing workbooks to return an error when clicking on the "Find Company" or "Find People" tabs in the Overview section.

July 16, 2025 at 06:28 AM EDT