Some Clay features, including enrichment panel search and Sculptor may e...
February 12, 2026 at 09:57 AM EST
Resolved after 3h 49m
Updates
Resolved
We’ve fully resolved the issue.
February 12, 2026 at 01:46 PM EST
Monitoring
We’ve fixed the issue and will continue to monitor the situation. We appreciate your patience.
February 12, 2026 at 12:33 PM EST
Identified
We've identified an issue affecting some Clay features, including Enrichment Panel Search and Sculptor. This is caused by an upstream provider experiencing issues.
Current workaround is to click on "View all enrichments" button at the bottom and then navigating to the enrichment action directly.
February 12, 2026 at 10:51 AM EST
Identified
We've identified an issue affecting some Clay features, including Enrichment Panel Search and Sculptor. This is caused by an upstream provider experiencing issues. We are currently working on a fix.
February 12, 2026 at 10:07 AM EST
Identified
We’ve identified the issue and are currently working on a fix.
February 12, 2026 at 09:57 AM EST