Back

Leadmagic Email Enrichment Timeouts

August 21, 2025 at 01:40 PM EDT Resolved after 1d

Updates

Resolved

We’ve fully resolved the issue.

August 22, 2025 at 03:48 PM EDT
Identified

We’re seeing timeouts from Leadmagic, which is part of our default Find Email waterfall. This is causing some email enrichment actions to fail.

We’re monitoring and will update once it’s resolved.

August 21, 2025 at 01:40 PM EDT