Back

app.clay.com is unavailable

June 6, 2025 at 06:19 PM EDT Resolved after 30m

Updates

Resolved

The issue has been resolved. There will be no further updates.

June 6, 2025 at 06:50 PM EDT
Monitoring

We have identified and reverted the change responsible for this outage. Downtime lasted from about 6:10pm to 6:30pm ET.

June 6, 2025 at 06:39 PM EDT
Investigating

app.clay.com is unavailable for all users. Engineers are investigating. Next update in 30 minutes or less

June 6, 2025 at 06:19 PM EDT