Back

Performance Issues

August 12, 2024 at 03:23 PM EDT Resolved after 19h 15m

Updates

Resolved

We’ve fully resolve the issue.

August 13, 2024 at 10:39 AM EDT
Monitoring

We've updated some backend systems and are seeing improved performance. You may still see slow performance on some of your enrichments as our system works through a backlog.

We'll continue to monitor things over night and provide further updates as needed. Thank you for your patience.

August 12, 2024 at 06:33 PM EDT
Investigating

Our engineers are making progress on the current issue. You may experience intermittent downtime in the app as we work to upgrade and restore some backend systems.

August 12, 2024 at 06:07 PM EDT
Investigating

We're still investigating the cause of the degraded performance. Its possible that you'll experience delays or failures when trying to run enrichments in your tables.

August 12, 2024 at 04:38 PM EDT
Investigating

We're still investigating the source of the issue.

August 12, 2024 at 04:03 PM EDT
Investigating

We’re currently investigating degrade performance across Clay. We will provide updates as soon as we have them.

August 12, 2024 at 03:23 PM EDT