Back

AI actions complete time are showing slower than usual.

May 25, 2026 at 06:00 AM EDT Resolved after 1h 57m

Updates

Resolved

We’ve fully resolved the issue. If AI actions still appear stuck, please try force re-running the cells. You can also filter rows by “is queued” and bulk force re-run those rows.

May 25, 2026 at 07:58 AM EDT
Monitoring

The latency issue has been mitigated. We will continue to monitor the situation. We appreciate your patience.

May 25, 2026 at 06:53 AM EDT
Investigating

Clay’s AI enrichment actions are showing slow performance to complete tasks. We’re aware of the issue, and our engineers are currently investigating it. Sorry for the inconvenience, and we’ll share updates as soon as possible.

May 25, 2026 at 06:12 AM EDT
Investigating

Clay’s AI enrichment actions are not completing tasks and remain stuck loading. We’re aware of the issue, and our engineers are currently investigating it. Sorry for the inconvenience, and we’ll share updates as soon as possible.

May 25, 2026 at 06:00 AM EDT