Back

app.clay.com is down

July 16, 2026 at 04:09 AM EDT Resolved after 5h 35m

Updates

Resolved

Clay was unavailable due to an upstream infrastructure provider outage that also affected several downstream providers, including intermittent SSO login issues. This has been resolved and the app is fully operational. Please re-send webhooks and re-run impacted cells.

July 16, 2026 at 09:44 AM EDT
Monitoring

The upstream infrastructure provider outage is affecting other services and some Clay features.  SSO to app.clay.com remains unstable, and some enrichment providers may experience errors.

July 16, 2026 at 05:16 AM EDT
Monitoring

The errors stem from an outage with an upstream provider. We implemented a temporary workaround and are seeing recovery.

July 16, 2026 at 05:06 AM EDT
Monitoring

We’ve fixed the issue and will continue to monitor the situation. We appreciate your patience.

July 16, 2026 at 05:03 AM EDT
Investigating

We are investigating errors accessing app.clay.com

July 16, 2026 at 04:09 AM EDT