Back

Scheduled Maintenance

July 25, 2026 at 09:00 PM EDT

Updates

Completed

Clay is back up and running. Thank you for your patience!

July 25, 2026 at 09:46 PM EDT
In Progress

Clay is temporarily offline to apply necessary infrastructure upgrades. Webhooks and callbacks from external providers will continue to be ingested during this timeframe. We will be back soon!

July 25, 2026 at 09:02 PM EDT
Scheduled

Clay will be temporarily offline to apply necessary infrastructure upgrades. Webhooks and callbacks from external providers will continue to be ingested during this timeframe.

July 25, 2026 at 09:00 PM EDT