Back

Stale jobs data before March 1

March 3, 2026 at 12:51 PM EST Resolved after 2d

Updates

Resolved

We’ve fully resolved the issue.

March 5, 2026 at 02:25 PM EST
Monitoring

A data provider has mitigated the issue and we continue to monitor their recovery. New searches and scheduled sources that were previously not receiving new records should now be current as of March 2nd. You may need to re-run your source or wait for scheduled sources to automatically re-run at their next scheduled time.

March 4, 2026 at 11:30 AM EST
Monitoring

A data provider outage resulted in stale jobs data, with no new jobs posted after March 1, leaving new searches and scheduled sources without records and last-24-hour searches returning empty results. Our data provider identified the cause, and is continuing to investigate to prevent recurrence, with delays expected to catch up soon.

March 3, 2026 at 12:54 PM EST
Monitoring

A data provider outage that caused stale jobs data, with no new jobs posted after March 1, leaving new searches and scheduled sources without records and last-24-hour searches returning empty results. Our data provider identified the cause, and is continuing to investigate to prevent recurrence, with delays expected to catch up soon.

March 3, 2026 at 12:51 PM EST