Back

Enrichment delays identified

July 8, 2026 at 12:05 PM EDT Resolved after 1h 17m

Updates

Resolved

We’ve fully resolved the issue.

July 8, 2026 at 01:22 PM EDT
Identified

We’ve identified an issue causing some enrichment to take longer than usual to complete. A fix is in progress.

July 8, 2026 at 12:05 PM EDT