Back

Issues with connecting to Apollo

October 16, 2025 at 08:07 AM EDT Resolved after 2h 54m

Updates

Resolved

We’ve fully resolved the issue.

October 16, 2025 at 11:01 AM EDT
Investigating

Some customers may be experiencing issues connecting to Apollo. Our team is actively investigating this.

October 16, 2025 at 08:07 AM EDT