Back

Trouble loading workbooks

September 26, 2024 at 01:02 PM EDT Resolved after 11d

Updates

Resolved

We’ve fully resolve the issue.

October 7, 2024 at 01:38 PM EDT
Monitoring

We’ve fixed the issue and will continue to monitor the situation. We appreciate your patience.

September 26, 2024 at 01:29 PM EDT
Investigating

We’re currently investigating an issue impacting the ability to load workbooks. We'll provide updates as soon as we have them.

September 26, 2024 at 01:02 PM EDT