Back

We're experiencing increased latency.

April 8, 2025 at 11:37 AM EDT Resolved after 11h 25m

Updates

Resolved

We’ve fully resolved the issue.

April 8, 2025 at 11:03 PM EDT
Investigating

We’re currently investigating an issue causing increased latency and timeouts inside the app. You may experience slower load times.

April 8, 2025 at 11:37 AM EDT