Back

Low Match Rates on Ads

July 15, 2026 at 11:53 AM EDT Resolved after 5h 33m

Updates

Resolved

We've solved this temporary issue contained to the Meta integration that should resolve for new syncs. We will continue monitoring match rates to ensure they continue recovering over time.

July 15, 2026 at 05:26 PM EDT
Investigating

We're investigating reports of low match rates on Meta for the Ads product.

July 15, 2026 at 11:53 AM EDT