Back

Company, People and Job search issues

March 24, 2025 at 12:49 PM EDT Resolved after 3m

Updates

Resolved

We’ve fully resolved the issue.

March 24, 2025 at 12:53 PM EDT
Investigating

We’re currently investigating an issue related to running company, people and job searches.

March 24, 2025 at 12:49 PM EDT