Some dropdown fields missing from enrichments
January 14, 2026 at 06:43 PM EST
Resolved after 1h 10m
Updates
Resolved
We’ve fully resolved the issue.
You may need to refresh your browser page to ensure you see the dropdowns appearing in your enrichments!
January 14, 2026 at 07:54 PM EST
Identified
We’ve identified the issue and are currently working on a fix.
January 14, 2026 at 07:12 PM EST
Investigating
We are aware of an issue where some dropdown fields are missing from enrichments. We’re currently investigating this issue.
January 14, 2026 at 06:43 PM EST