Sequencer displaying 400s and experiencing errors in Clay
November 18, 2025 at 08:52 AM EST
Resolved after 1h 38m
Updates
Resolved
Following an earlier outage with an upstream provider, Clay is now running as expected.
November 18, 2025 at 10:30 AM EST
Investigating
We’re currently experiencing an issue due to issues with an upstream provider, which is affecting Sequencer and some other parts of Clay. You may notice slower performance or errors in this time.
Our team is actively monitoring the situation, and we’ll keep you updated as we work on a fix. We’ll share more information as soon as we have it.
Thank you for your patience.
November 18, 2025 at 08:52 AM EST