Experiencing performance issues with our SFDC actions
March 19, 2025 at 02:52 PM EDT
Resolved after 69d
Updates
Resolved
this was resolved several weeks ago but the status was not updated - updating to reflect that
May 27, 2025 at 04:17 PM EDT
Monitoring
We’ve fixed the issue and will continue to monitor the situation. We appreciate your patience.
March 19, 2025 at 03:15 PM EDT
Identified
We've found a potential cause for the error.
March 19, 2025 at 03:04 PM EDT
Investigating
We’re currently investigating this issue.
March 19, 2025 at 02:52 PM EDT