Back

HubSpot Source Connection Returning Fewer Results Than Expected

March 12, 2026 at 07:37 PM EDT Resolved after 40m

Updates

Resolved

We’ve fully resolved the issue. Users can refresh their tables and re-run the HubSpot source.

March 12, 2026 at 08:18 PM EDT
Investigating

We’re investigating issues with our HubSpot source connection. You may see fewer results than expected.

March 12, 2026 at 07:37 PM EDT