Find Employee Headcount by Criteria
April 6, 2026 at 07:13 PM EDT
Resolved after 17m
Updates
Resolved
We’ve fully resolved the issue. Please re-run the impacted Find Employee Headcount by Criteria enrichment to return successful results.
April 6, 2026 at 07:31 PM EDT
Investigating
Customers running the "Find Employee Headcount by Criteria" enrichment may see errors. We’re currently investigating this issue.
April 6, 2026 at 07:13 PM EDT